SCT/SCT Inst delays - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
This incident has been resolved. A few transfers are taking longer to recover.
Posted May 31, 2023 - 10:32 CEST
Monitoring
A fix has been implemented by sepa infrastructure and we are monitoring.
Payments are going through.

We will be catching up with the queue right now.
Posted May 31, 2023 - 10:17 CEST
Update
Even most payments have gone through normally in the last two hours some of them are having abnormal long times to be processed.

We are working diligently with the banking network to fix the issue as soon as possible.
Posted May 31, 2023 - 09:41 CEST
Investigating
We have detected an issue with our banking infrastructure that is making SEPA SCT and SCT-INST transfers take longer than usual to be executed.

Customers should expect delays.

We are working diligently with the banking network to fix the issue as soon as possible.
Posted May 31, 2023 - 06:26 CEST
This incident affected: Payments, Banking, and Salary Advance.