Payments are now processing successfully. We're currently working through the backlog of delayed payments and continue to monitor the situation.
Posted Jan 12, 2026 - 07:12 CET
Identified
Modulr has identified the issue as a connectivity problem with the banking network. Payments are currently delayed and unlikely to process until later today (around 8:00 UTC). We will resume payment execution as soon as the issue is resolved.
Posted Jan 12, 2026 - 05:09 CET
Update
We are continuing to investigate this issue.
Posted Jan 12, 2026 - 04:22 CET
Investigating
We have identified an issue within the banking infrastructure that is currently impacting payments. We are placing the current payments on delay. Our partner is investigating. We will be providing regular updates.
Posted Jan 12, 2026 - 04:22 CET
This incident affected: Banking Infrastructure (Modulr's payment processor).