SEPA Transfers - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
Issue is over and payments are now going through.
All delayed payments have been pushed through, a few payments will still take a time to be confirmed.
Apologise for the inconvenience
Posted Feb 15, 2024 - 17:45 CET
Investigating
There is an issue with banking infrastructure generating transfer not being confirmed.

As a result, there is an abnormally long queue to process payments, so customers should expect delays.

We are working diligently with the banking network to fix the issue as soon as possible.
Posted Feb 15, 2024 - 16:25 CET
This incident affected: Payments, Banking, and Salary Advance.