Modulr payments intermitent issues

Incident Report for Devengo

Resolved

Payments have beeenprocessed as expected for the last 90 minutes. issue has been resolved.


ve be
Posted May 21, 2026 - 06:22 CEST

Monitoring

Payments router through modulr have some delay but are being executed without error.
Posted May 21, 2026 - 04:05 CEST

Investigating

RT1 banking network is experiencing intermittent issues again. Following the events of the past few hours, we have paused all outbound SEPA payments. Any payments submitted while the pause is in effect will be held and will not be processed until we identify the root cause and the situation stabilises.

We sincerely apologise for the recurrence of this issue, which is unfortunately beyond our control.
Posted May 21, 2026 - 02:04 CEST
This incident affected: Banking Infrastructure (Modulr's payment processor).