Short interruptions in Modulr payment processor

Incident Report for Devengo

Resolved

Everything has been working as expected for the last 90 minutes, we close the incident for now. All pending payments will be reviewed ASAP.
Posted May 18, 2026 - 20:03 CEST

Monitoring

Modulr seems stable, we keep monitoring the situation.
Posted May 18, 2026 - 19:27 CEST

Update

Modulr still have some intermittent issues. We keep an eye on it.
Posted May 18, 2026 - 18:52 CEST

Investigating

Modulr is experiencing issues and some of the payments are being getting stalled.

As a precautionary measure, we have temporarily paused payment processing through Modulr. Payments will be delayed in the meantime.

This issue only affects payments of clients with accounts issued by Modulr.

We will continue to provide regular updates.
Posted May 18, 2026 - 18:31 CEST
This incident affected: Banking Infrastructure (Modulr's payment processor).