Bank CAGLESMMXXX ABANCA Offline - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
Abanca is back online. Delayed payments have been processed.
Posted Jul 19, 2024 - 11:17 CEST
Update
Abanca is offline. They are working on it: https://x.com/SomosABANCA/with_replies
Payments will see delays to be processed.
Posted Jul 19, 2024 - 09:45 CEST
Identified
Payments sent to BIC CAGLESMMXXXAbanca are not being processed instantly at the moment. Payments will see delays to be processed.
Posted Jul 19, 2024 - 07:55 CEST
This incident affected: Payments API and Banking network.