We have received confirmation from our banking provider that there was anomalous behavior during the night and until 8:30 AM CEST this morning in the banking infraestructure.
Payments continue to process normally, as well as VoPs and Account Holder Verifications.
All payments affected by the incident have already been processed. We sincerely apologize for the inconvenience caused.
If you need any further clarification, please contact us in support@devengo.com.
Posted May 06, 2026 - 12:41 CEST
Monitoring
We are still awaiting further updates from our banking provider’s provider. However, service has now returned to normal, and payments are being processed as expected.
We are currently processing payments that were previously delayed. VoP and Account Holder Verification are now fully operational again.
We will continue to monitor the situation closely and provide further updates as needed.
Posted May 06, 2026 - 08:42 CEST
Investigating
We have identified an incident in our banking providers affecting payments processed via Devengo. As a precaution, we have temporarily suspended payment processing through this provider. Any payments received during this period will be marked as delayed until the issue is resolved.
Affected: Payment for accounts issued by Devengo Verification of payees Account holder verifications
Payments of Modulr issued accounts are not being affected.
We will provide regular updates on our status page.
Posted May 06, 2026 - 08:11 CEST
This incident affected: Banking Infrastructure (Banking network).