SCT and SCT-Inst delays - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
This incident has been resolved.
Posted Nov 18, 2023 - 12:03 CET
Monitoring
Systems are operational again. We are monitoring all operations and executing delayed payments.
Posted Nov 18, 2023 - 11:53 CET
Investigating
We have detected an issue with our banking infrastructure that is making SEPA transfers to take longer than usual to be executed.

As a result of these execution times, there is an abnormally long queue to process payments so customers should expect delays.

We are working diligently with the banking network to get the issue fixed as soon as possible.
Posted Nov 18, 2023 - 10:30 CET
This incident affected: Banking.