Issue processing payments from Devengo's own payment processor

Incident Report for Devengo

Resolved

Our payment provider experienced a brief communication outage that prevented us from establishing a connection with them. The issue is now over. Payments are processing normally, and all previously queued transactions have been successfully completed.

If you need any further clarification, please do not hesitate to contact us at support@devengo.com
Posted Nov 17, 2025 - 08:51 CET

Investigating

Payments sent from accounts issued by Devengo's BIC are being held while we investigate a network connectivity issue.
Posted Nov 17, 2025 - 07:43 CET
This incident affected: Banking Infrastructure (Devengo's Payment processor).