Issue with Instant Payments routed through Modulr

Incident Report for Devengo

Resolved

The incident has been resolved.
Payments are now processing normally.
Delayed payments have been successfully processed.
A few payments from the beginning of the incident require manual review due to a block by our provider’s TMS and should be processed by tomorrow at the latest.

For further clarifications, please don’t hesitate to contact support@devengo.com
Posted Oct 23, 2025 - 19:37 CEST

Investigating

We have identified an issue within the banking infrastructure that is currently impacting payments.
We are placing the current payments on delay. Our partner is investigating.
We will be providing regular updates.
Posted Oct 23, 2025 - 19:13 CEST
This incident affected: Payments API and Banking Infrastructure (Modulr's payment processor).