SEPA Transfers - Delay of aprox 10 min
Incident Report for Devengo
Resolved
Issue is over. We will be monitoring. Payments are being released immediately.
Posted Mar 08, 2024 - 13:25 CET
Identified
We are experiencing a delay of aprox 10 min in a payment to be executed and upadated. We are working on it and we expect to have it solve shortly.
We apologize for the inconvenience.
Posted Mar 08, 2024 - 12:19 CET
This incident affected: Payments, Banking, and Salary Advance.