SEPA Transfers - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
Issue is over and payments are now going through.
All delayed payments are being pushed through at the moment, it can take some time till all the queue is processed.
Posted Jan 24, 2024 - 15:07 CET
Investigating
There is an issue with banking infrastructure generating transfer not being confirmed.

As a result, there is an abnormally long queue to process payments, so customers should expect delays.

We are working diligently with the banking network to fix the issue as soon as possible.
Posted Jan 24, 2024 - 14:30 CET
This incident affected: Payments, Banking, and Salary Advance.