All payments that were in delayed status have now been successfully processed. Payments affected at the very beginning of the incident have also been now been processed.
We apologise for the disruption.
If you require any further clarification, please don’t hesitate to contact us at support@devengo.com.
Posted Jun 26, 2025 - 18:15 CEST
Monitoring
Our upstream provider, has confirmed that a recent change deployed by their engineering team caused disruption to payment processing. This change has now been rolled back, and service has return to normal.
We are closely monitoring the situation and will provide further updates.
Delayed payments are being processed now.
Posted Jun 26, 2025 - 18:01 CEST
Update
We are continuing to investigate this issue.
Posted Jun 26, 2025 - 17:33 CEST
Investigating
We have identified an incident affecting the banking infrastructure, which is impacting a high percentage of outgoing payments. As a result, we are temporarily placing payments in a delayed status until the issue is resolved. The issue has been escalated to the relevant parties. We will keep you updated.
Posted Jun 26, 2025 - 17:30 CEST
This incident affected: Payments API and Banking network.