SCT and SCT-Inst delays - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
Partner has implemented fix and everything is working as expected again. There is a long queue of payments that are being processed right now. This will take some minutes till they all go through.
Posted Dec 07, 2023 - 11:10 CET
Identified
Our PSP provider is having an issue that has already identified. They are working diligently an expect to have it fix shortly.

We have an abnormally long queue to process payments, so customers should expect delays.

We are working diligently with the banking network.
Posted Dec 07, 2023 - 10:23 CET
This incident affected: Payments, Banking, and Salary Advance.