SEPA Transfers - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
Our partner has finally solved the issue. Payments are being confirmed. Delayed payments are going now through. It will take some minutes-
Apologise for the inconvenience.
Posted Feb 23, 2024 - 22:41 CET
Update
Out banking partner is still investigating the issue.
We apologise the inconvenience caused.
Posted Feb 23, 2024 - 20:47 CET
Investigating
There is an issue with banking infrastructure generating transfer not being confirmed.

As a result, there is an abnormally long queue to process payments, so customers should expect delays.

We are working diligently with the banking network to fix the issue as soon as possible.
Posted Feb 23, 2024 - 18:07 CET
This incident affected: Payments, Banking, and Salary Advance.