We will be undergoing scheduled maintenance during this time.
Posted Mar 31, 2026 - 19:57 CEST
Update
Regarding this maintenance, please note that all VoPs,regardless of the account issuer, will be rejected during the maintenance window. You will be able to retry them once the maintenance is completed.
Posted Mar 31, 2026 - 19:55 CEST
Scheduled
We have a scheduled IT maintenance planned for April 6th 2026 between 07:00 PM UTC and 10:00 PM UTC. We expect it to take no more than 3 hours.
During the maintenance - Payments from accounts issued by Devengo will be set to a delayed status and will be processed once the maintenance is completed. - Account holder verifications will be unavailable during this period. The API will return an error for verification requests. - Payments from accounts issued by Modulr will continue to be processed as usual.
If you have any questions or need further clarification, please contact us at support@devengo.com
Posted Mar 26, 2026 - 20:13 CET
This scheduled maintenance affects: Banking Infrastructure (Devengo's Payment processor) and Verification of Payee API, Account Holders Verification API.