SEPA Transfers - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
Fix has been implemented. New payments are being confirmed as normal. Previous enqueued payments are being now sent and will be process in the next minutes.
Posted Mar 04, 2024 - 14:21 CET
Identified
PSP has identified the issue and a fix is being applied.
Posted Mar 04, 2024 - 14:03 CET
Investigating
There is an issue with banking infrastructure generating transfers not being confirmed. The issue has been already identified.

As a result, there is an abnormally long queue to process payments, so customers should expect delays.

We are working diligently with the banking network to fix the issue as soon as possible.
Posted Mar 04, 2024 - 13:31 CET
This incident affected: Payments, Banking, and Salary Advance.