SCT-Inst - Banking Issue

Incident Report for Devengo

Resolved

All previously blocked payments have now been successfully processed.

The root cause of the issue has still not been shared.

For any further clarification, please feel free to contact us at support@devengo.com.

We apologize for the inconvenience caused.
Posted Jul 08, 2025 - 17:28 CEST

Monitoring

Delayed payments have been processed.

The initial payments affected at the start of the issue remain blocked, and the provider is actively working to resolve them. Please do not attempt to retry these payments.

We will continue to provide updates on the status of the blocked payments and the underlying cause of the issue.
Posted Jul 08, 2025 - 14:58 CEST

Update

Our payment provider has resumed normal operations. Current transactions are being processed as expected, and we have begun addressing previously delayed payments.
Posted Jul 08, 2025 - 14:12 CEST

Investigating

Our provider has started blocking a high volume of payments, so we’ve temporarily delayed processing new ones. The issue has been reported, and we will keep you informed of any updates.
Posted Jul 08, 2025 - 13:18 CEST
This incident affected: Payments API and Banking network.