General issue with spanish banks

Incident Report for Devengo

Resolved

All delayed payments have been processed. Everything is working as expected.
Posted Jun 07, 2025 - 00:46 CEST

Monitoring

Iberpay has reported they have solved the issue. We have resumed operations and payments are being processed again.

All delayed payments are being processed as we speak.
Posted Jun 07, 2025 - 00:31 CEST

Identified

Iberpay, the Spanish ACH system, has reported an issue causing most transactions involving a Spanish bank—either as the origin or destination—to fail.

We have put the system in delay mode until this is resolved.

Some of the transactions linked to Spanish banks from the beginning of the issue (around 23:30 CEST)have been processed as traditional wire transfers and they will arrive on Monday. We are very sorry for the inconvenience this will cause you and your customers.
Posted Jun 07, 2025 - 00:11 CEST
This incident affected: Banking network.