SEPA Transfers - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
All delayed payments have been processed and the system is fully operational again. There is a small set of payments from the beginning of the incident that need to be inspected yet.

We apologize for the inconvenience that this issue has caused and thank you for your patience.
Posted Feb 17, 2024 - 01:34 CET
Monitoring
Our partner has finally solved the issue. Payments are finally flowing again. We will start sending delayed payments now.
Posted Feb 17, 2024 - 01:18 CET
Identified
Partner has identified the issue.
Posted Feb 16, 2024 - 22:18 CET
Update
Out banking partner is investigating the issue.
We apologise the inconvenience caused.
Posted Feb 16, 2024 - 22:11 CET
Investigating
There is an issue with banking infrastructure generating transfer not being confirmed.

As a result, there is an abnormally long queue to process payments, so customers should expect delays.

We are working diligently with the banking network to fix the issue as soon as possible.
Posted Feb 16, 2024 - 20:36 CET
This incident affected: Banking.