SCT-INST delays - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
Held payments have gone through. We will keep on monitoring.
We apologise for any inconvenience caused.
Posted Jan 08, 2024 - 19:47 CET
Monitoring
PSP has identified and implemented a fix. We are now sending delayed payments. We will be closely monitoring.
Posted Jan 08, 2024 - 19:27 CET
Update
Unfortunately the psp is still investigating this matter. All payments are being held. As soon as the problem has been resolved they will be executed. We apologise for the inconvenience.
Posted Jan 08, 2024 - 18:15 CET
Update
We are continuing to work with upstream banking rails to find the problem that is generating the delays.
Posted Jan 08, 2024 - 16:21 CET
Investigating
We have detected an issue with one of our banking partners that is making SEPA transfers to take longer than usual to be executed.

As a result of these execution times, there is an abnormally long queue to process payments so customers should expect delays.

We are working diligently with the banking network to get the issue fixed as soon as possible.
Posted Jan 08, 2024 - 14:37 CET
This incident affected: Payments, Banking, and Salary Advance.