SCT-Inst delays - Banking Infrastructure Issue

Incident Report for Devengo

Resolved

Payments are flowing again. Delayed payments are being processed as we speak.
Posted Jun 07, 2025 - 09:11 CEST

Investigating

We have identified an issue within our banking infrastructure that is causing delays in the execution of SEPA transfers.

As a result, we are temporarily placing some payments in a delayed status until the issue is resolved.

We are working diligently with the banking network to get the issue fixed as soon as possible.
Posted Jun 07, 2025 - 08:55 CEST
This incident affected: Banking network.