SCT-Inst - Banking Infrastructure Issue

Incident Report for Devengo

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 20:17 CEST

Monitoring

The incident appears to be over, and current payments are now being processed.

We will proceed with releasing the payments that were previously placed on hold.
Posted Jul 03, 2025 - 14:39 CEST

Investigating

We have identified an issue within the banking infrastructure that is currently impacting payments to Spanish IBANs. The Spanish clearing house has confirmed that an investigation is underway.

We are placing the current payments on delay until the incident has been resolved.

We will be providing regular updates.
Posted Jul 03, 2025 - 14:20 CEST
This incident affected: Payments API and Banking network.