SCT-Inst delays - Banking Infrastructure Issue

Incident Report for Devengo

Resolved

The issue has been solved. New payments are being processed right now and we’re starting to process the queue.
We’ll keep you updated, but if you have any questions, feel free to contact us at support@devengo.com.
Posted Jun 13, 2025 - 10:22 CEST

Update

Issue is still ongoing we expect to have an update in the next hour.
Posted Jun 13, 2025 - 09:30 CEST

Update

Bank of Lithuania has confirmed that the issue still affecting IBANS from ES and FR, will not be solved until tomorrow.
We are sorry for the impact this is causing.
Posted Jun 12, 2025 - 19:45 CEST

Update

The BOL (Bank Of Lithuania) has still not resolved the issue. At this point, we don’t expect it to be resolved until tomorrow.
Take into consideration incoming payments are also being affected.
We’ll keep monitoring the situation closely and will let you know right away if it’s resolved sooner.
Posted Jun 12, 2025 - 19:00 CEST

Update

The BOL (Bank Of Lithuania), the channel our provider uses has acknowledge and issue for Spanish and French issue IBANs. Customers having a bank account issued in the Netherlands or Ireland are working as expected.

This has been labeled with P1 priority and their are working actively on it.
Posted Jun 12, 2025 - 17:01 CEST

Update

Issue persists. PSP is actively working to resolve the issue as a top priority.
We apologize for the inconvenience this is causing to your operations.
Posted Jun 12, 2025 - 11:56 CEST

Identified

Our Payment Service Provider (PSP) has identified an issue affecting the SEPA service. They are actively working to resolve the matter as quickly as possible.

We apologize for the inconvenience this is causing to your operations.
Posted Jun 12, 2025 - 10:40 CEST

Investigating

We have identified an issue within our banking infrastructure that is causing delays in the execution of SEPA transfers.

As a result, we are temporarily placing payments in a delayed status until the issue is resolved.

We are working diligently with the banking network to get the issue fixed as soon as possible.
Posted Jun 12, 2025 - 09:28 CEST
This incident affected: Payments API and Banking network.