SCT-Inst delays
Incident Report for Devengo
Resolved
Payments are finally being processed.
Posted Mar 18, 2024 - 05:23 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 17, 2024 - 17:10 CET
Identified
One of our banking partners is having an issue after today's update in the SEPA Network. This is causing payments routed with them to be delayed.

We are working diligently with the banking network to get the issue fixed as soon as possible.
Posted Mar 17, 2024 - 10:43 CET
This incident affected: Banking.