SCT-INST delays - Banking Infrastructure Issue
Incident Report for Devengo
Resolved
This incident has been resolved.
Posted Dec 16, 2023 - 10:04 CET
Monitoring
All systems are operational right now.

Delayed payments are being executed as we talked.
Posted Dec 16, 2023 - 09:43 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 16, 2023 - 09:31 CET
Update
We continue investigating this issue with our banking partners.
Posted Dec 16, 2023 - 08:39 CET
Investigating
We have detected an issue with one of our banking partners that is making SEPA transfers to take longer than usual to be executed.

As a result of these execution times, there is an abnormally long queue to process payments so customers should expect delays.

We are working diligently with the banking network to get the issue fixed as soon as possible.
Posted Dec 16, 2023 - 07:39 CET
This incident affected: Payments, Banking, and Salary Advance.