Bank Offline OPENESMMXXX - Open Bank - Banking Infrastructure Issue

Incident Report for Devengo

Resolved

Open Bank is now back online. All delayed payments sent that where in delayed have been processed.
Posted Jun 06, 2025 - 07:14 CEST

Investigating

Investigating
The SCT-INST infrastructure of banks with BIC= OPENESMMXXX is again offline.
At the moment payments to this BIC are being delayed and will be retried later.
Posted Jun 05, 2025 - 20:43 CEST
This incident affected: Banking network.