SCT-Inst delays - Banking Infrastructure Issue

Incident Report for Devengo

Resolved

A fix has been implemented, and we are actively monitoring the situation. Delayed payments are currently being processed; however, it will take some time for all of them to be completed. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Jun 04, 2025 - 23:37 CEST

Update

We regret to inform you that the situation has not improved. As a result, we’ve made the decision to move all payments to delayed status until the issue is resolved on our provider’s side.

We fully understand the seriousness of the matter and are actively following up with the provider to ensure it is addressed as soon as possible. We sincerely apologize for the inconvenience.
Posted Jun 04, 2025 - 19:10 CEST

Identified

Our provider has identified the issue affecting some payments. The fix is being implemented.
Posted Jun 04, 2025 - 17:39 CEST

Update

Our partner is continuing to investigate the matter. We are actively collaborating with our banking partners to resolve the issue as a top priority. We sincerely apologise for any inconvenience this may have caused.
Posted Jun 04, 2025 - 16:47 CEST

Investigating

We have identified an issue within our banking infrastructure that is causing delays in the execution of SEPA transfers.

As a result, we are temporarily placing some payments in a delayed status until the issue is resolved.

We are working diligently with the banking network to get the issue fixed as soon as possible.
Posted Jun 04, 2025 - 15:42 CEST
This incident affected: Banking network.