Issue with Instant Payments routed through Modulr

Incident Report for Devengo

Resolved

All impacted payments have now been reviewed and processed.
If you have any questions or need further assistance, please don't hesitate to contact us in support@devengo.com
Posted Oct 29, 2025 - 21:49 CET

Monitoring

The incident has been resolved.
Payments are now processing normally.
Delayed payments are being processed.
A few payments from the beginning of the incident require manual review. We will be working on them and inform shortly.
Posted Oct 29, 2025 - 14:36 CET

Investigating

We have identified an issue within the banking infrastructure that is currently impacting payments.
We are placing the current payments on delay. Our partner is investigating.
We will be providing regular updates.
Posted Oct 29, 2025 - 14:16 CET
This incident affected: Payments API and Banking Infrastructure (Modulr's payment processor).